Хитрый глюк Win98 TCP/IP

 
+
-
edit
 

Balancer

администратор
★★★★☆
Только что одному товарищу на работе потребовалась Win98 (опадают последние бастионы Win95 - софтина к диктофону требовала не менее Win98). Поскольку добра у него там полно всякого, переустановил систему поверх имеющейся. Win95 была OSR2.1 русская. Win98 - тоже русская.

Что теперь имеется.

Локальная сеть (NetBIOS через TCP/IP, не NetBEUI!) пашет.
Все машины пингуются.
Но при попытке установить любое соединение (telnet, www, pop3) с любой машиной - облом. "Не могу установить соединение" без объяснения причин. В route, вроде, всё ок. Пробовал сносить и переустанавливать как сетевуху, так и протоколы. Всё то же самое. NetBIOS через TCP/IP пашет, пинги идут, а интернет - не пашет... :(

Все программы закрыты, никаких файрволов нет, да и под Win95 всё ок было...

У кого какие мысли есть?

Понятно, переустановить всё с нуля можно, но там СТОЛЬКО всякого нужного софта... Это на неделю потом всё восстанавливать...
 

yuu2

опытный



Может это св-во самой Win со временем коньки отбрасывать?



Я с пол-года назад переезжал с машины на машину. На старой сетевуха под Win98 работала, на новой (с того же дистрибутива, с теми же драйверами) - ни в какую. Думал - что-то аппаратное, ан нет - на том же самом железе под XP всё идёт без проблем.
 
+
-
edit
 

Balancer

администратор
★★★★☆
Да нет, тут всё хитрее. Железо и под 98-й работает. Сеть же локальная видится. Значит не только сетевуха работает. И даже не только TCP/IP. Но и непосредственно TCP! Более того, пинги идут - это ICMP... В общем, непонятно. Человеку работать надо, так что восстановил 95-ю откатом (впервые в жизни воспользовался!) - сейчас всё ок снова. А потом, будет время, XP ему поставлю с нуля.
 

TbMA

опытный



Была недавно такая-же история. Машина - w2k. Дозванивается, логинится, но ничего кроме  пинга не работает.


Все сервисы - dns, http и пр. и пр. Единственное что я нашел - какой-то троян, который Нортон поставил на карантин (файл назывался что-то вроде winexe.exe в system).


Имхо - полетел DCOM (и/или winsock).


Пинг и пр. использует raw сокеты для работы  - поэтому и выжил.
 
А какая версия WIN98 установлена-PE или SE?
 

AK

опытный

Можно попробовать опять поставить 98SE, но с другого компакта. Некоторые версии поверх ставились исключительно криво, а другие - ниче так.
Вы думаете легко быть Главным Злодеем в мире животных?
Всегда одно и то же, одно и то же...
 
+
-
edit
 

Balancer

администратор
★★★★☆
Да ладно, отбой, как будет время - поставлю XP ему. PII-350 и 128Мб RAM позволяют...
 

Misha

новичок
Balancer>Только что одному товарищу на работе потребовалась Win98 (опадают последние бастионы Win95 - софтина к диктофону требовала не менее Win98). Поскольку добра у него там полно всякого, переустановил систему поверх имеющейся. Win95 была OSR2.1 русская. Win98 - тоже русская.

Что теперь имеется.

Локальная сеть (NetBIOS через TCP/IP, не NetBEUI!) пашет.
Все машины пингуются.
Но при попытке установить любое соединение (telnet, www, pop3) с любой машиной - облом. "Не могу установить соединение" без объяснения причин. В route, вроде, всё ок. Пробовал сносить и переустанавливать как сетевуху, так и протоколы. Всё то же самое. NetBIOS через TCP/IP пашет, пинги идут, а интернет - не пашет... :(

Все программы закрыты, никаких файрволов нет, да и под Win95 всё ок было...

У кого какие мысли есть?

Понятно, переустановить всё с нуля можно, но там СТОЛЬКО всякого нужного софта... Это на неделю потом всё восстанавливать...




Была у меня одна засада, но связано это было с процом. Он был от известной фирмы AMD. Под виндой вся та же хрень, как и описывали, а под DOSом все ОК.
 
+
-
edit
 

Balancer

администратор
★★★★☆
Блин. Та же фигня на WinME. Проводил сегодня чистку одной машинки и вот. Локальная сеть (через TCP/IP!) пашет на ура. Гейт пингуется. Но телнет (и, понятно, прочие интернет-приблуды) не цепляется к нему ни на какой порт. в route - всё ок. Да и пингуется же... Даже DNS пашет... Сеть сносил/пеерставлял, TCP/IP - тоже. Дистрибутива WinME нет, чтобы переустановить поверх. Winsock2 - только для Win95. У кого какие мысли куда копать?
 
BG Реконструктор #03.07.2003 16:06
+
-
edit
 
Balancer>Да ладно, отбой, как будет время - поставлю XP ему. PII-350 и 128Мб RAM позволяют...


Ой, не надо! У моего знакомого - PII-450/128 и там ТАКОЕ творится...
 
BG Реконструктор #03.07.2003 16:07
+
-
edit
 
Balancer>Блин. Та же фигня на WinME. Проводил сегодня чистку одной машинки и вот. Локальная сеть (через TCP/IP!) пашет на ура. Гейт пингуется. Но телнет (и, понятно, прочие интернет-приблуды) не цепляется к нему ни на какой порт. в route - всё ок. Да и пингуется же... Даже DNS пашет... Сеть сносил/пеерставлял, TCP/IP - тоже. Дистрибутива WinME нет, чтобы переустановить поверх. Winsock2 - только для Win95. У кого какие мысли куда копать?


Может на гейтуейе фильтр какой-то? Или на самой машине? Пробывал цеплятся софтом, который выписывает номер ошибки? (она обычно имеет номер >10000)
 
+
-
edit
 

Balancer

администратор
★★★★☆
Resurrector>Ой, не надо! У моего знакомого - PII-450/128 и там ТАКОЕ творится...


Выруби все резиденты, останови лишние сервисы, отключи навороты интерфейса. XP тогда жрёт около 60Мб оперативки. Что с WinME сопоставимо...
 
+
-
edit
 

Balancer

администратор
★★★★☆
Resurrector>Может на гейтуейе фильтр какой-то?


Нет. Я же писал, что не только гейт не отзывается, но и другие компы. Кроме того, до "оптимизации" сеть же работала :)
 

TbMA

опытный

Тот глюк который я описывал выше, вылечился установкой ХР поверх.
 

hcube

старожил
★☆

Прописать DNS хорошо бы ручками. Да и провайдеры обычно привязывают аккаунт на роутере к паре IP-MAC. Тоже хорошо бы проверить. Ну... и проще всего снести винду под корень и поставить заново...
Убей в себе зомби!  
+
-
edit
 

Balancer

администратор
★★★★☆
hcube>Прописать DNS хорошо бы ручками. Да и провайдеры обычно привязывают аккаунт на роутере к паре IP-MAC. Тоже хорошо бы проверить. Ну... и проще всего снести винду под корень и поставить заново...


Да машино-та во внутренней сетке. И DNS и гейт - это мой же сервер :) И никакой привязки там нет. В общем, буду ставить XP. Заодно посмотрим, как она будет жить на Celeron 417/96RAM :)
 
+
-
edit
 

Balancer

администратор
★★★★☆
Всё. Поставил XP. Живёт нормально. Даже кое-какие красивости оставил :) Типа теней под мышью...
 
+
-
edit
 

Mishka

модератор
★★☆
Resurrector>>Может на гейтуейе фильтр какой-то?

Balancer>Нет. Я же писал, что не только гейт не отзывается, но и другие компы. Кроме того, до "оптимизации" сеть же работала :)



А ты пингуешь по имени или по адресу?

И еще, телнетишься как - по адресу или имени?

Можешь установить etherreal и поснифать пакеты во время телнет сессий как на самой машине и на телнет сервере?
 
+
-
edit
 

Balancer

администратор
★★★★☆
Естественно, по адресу :) Кроме того, я же указывал, что DNS работал. Внешние адреса резольвились. Впрочем, опять это уже не актуально, поскольку снёс я WinME :)
 
BG Реконструктор #06.07.2003 01:20
+
-
edit
 
Balancer>Всё. Поставил XP. Живёт нормально. Даже кое-какие красивости оставил :) Типа теней под мышью...



Да ну, не верю! :blink:
 
+
-
edit
 

Balancer

администратор
★★★★☆
Resurrector>Да ну, не верю! :blink:


Ну, не верь. Opera с кучкой страниц + ICQ 2003Pro + Spider + SpiderMal - памяти занято 98Мб. При 96мб это вполне вольготно. Если ещё Word или Excel загрузить - тсартует быстро, но потом при обращении, скажем, к Опере - подгружает её из свопа. Кстати, я даже сервисы почти никакие не останавливал. Я ими всего пару мегабайт оперативки выкроил.
 

в начало страницы | новое
 
Поиск
Настройки
Твиттер сайта
Статистика
Рейтинг@Mail.ru