Уф! Давний спор Linux vs Windows решён!

 

ak03

новичок
ak03>> Нечестно :) У KDE портеров сдох кластер с романтическим именем fruitsalad
Balancer> Ну, я не знал!
ak03>>Что имеется под автоматичностью я не в курсе, во FreeBSD установка порта в нестандартный prefix/ потребует некоторого внимания.
Balancer> В Gentoo есть так называемая система слотов. И если программа хочет позарез использовать версию какого-то пакета, отличного от системного, то эта версия может стать "параллельно" основной. Например, почти у всякого юзера gentoo таким макаром стоит 5..10 версий autoconf.
Balancer> Когда обновляешь web-apps (всякие phpMyAdmin, phpBB, mediawiki и т.п.), то новые версии ставятся слотами. Можно потом одной командой выборочно ставить заданный пакет на указанный виртуальный хост в указанный каталог, обновлять уже имеющийся и т.п. Естественно, старые версии можно выборочно удалять :)
Balancer>
code text
  1. Balancer> # emerge -pC phpmyadmin
  2.  >>>> These are the packages that I would unmerge:
  3. Balancer>  dev-db/phpmyadmin
  4. Balancer>     selected: 2.6.1_p2-r1 2.6.2-r1 2.6.2-r2 2.6.0_p3 2.6.1_p2 2.6.1_rc1 2.6.2_rc1
  5. Balancer>    protected: none
  6. Balancer>      omitted: none
  7.  >>>> 'Selected' packages are slated for removal.
  8.  >>>> 'Protected' and 'omitted' packages will not be removed.
  9. Balancer>

Balancer> Как видно, phpMyAdmin у меня установлен 7-ю версиями :) [»]

Подозреваю, что с этим у FreeBSD не так красиво, но всё же...
% pkg_info auto<Tab>
autoconf-2.13.000227_5 autoconf-2.59_2 automake-1.5_2,1
autoconf-2.53_3 automake-1.4.6_1 automake-1.9.5
 

в начало страницы | новое
 
Поиск
Настройки
Твиттер сайта
Статистика
Рейтинг@Mail.ru